Luxeritas 3.0.3 リリース(Font Awesome バージョン選択機能追加)

Luxeritas 3.0.3

Luxeritas 3.0.3 をリリースしました。

5月11日から AMP でも Font Awesome 5 の CDN が利用できるようになったため、Font Awesome 5 を使用できるようにしました。

独自に Font Awesome 4 を利用してる方はバージョンを 4 に設定できる機能もあります。

アップデートに関する注意

デフォルトの Font Awesome バージョンが 5 になります。
Font Awesome 4 をご利用の方は Font Awesome のバージョン設定を 4 に変更してください。

その他の変更点は改訂履歴、または開発者ブログの記事をご覧ください。

スポンサーリンク

改訂履歴

機能拡張

  1. Font Awesome 4 と 5 を選択できる機能追加

その他の変更

  1. Amazon のサイト構成変更によってブログカードで Amazon 用の特殊処理が必要なくなったので特殊処理部分を消した
  2. タグ内の style 属性で ' や " を書くと AMP 置換で style 属性を消去しきれないことがあるので正規表現を少し変えた
  3. thk_comment_fields フィルターフック追加(使い方とかは、いずれ書く)
  4. グローバルナビの設定が「非表示」&「スクロール固定」という意味のない組み合わせになってると、コンソールで Javascript のエラーが出るので一応修正